Cómo cambiar la versión de PHP en cPanel

Cambiar la versión de PHP en cPanel para toda tu cuenta o subdominio #

Desde su cPanel puede cambiar la versión de PHP para toda su cuenta o un subdominio sigue estos pasos:

Ingresa a su cuenta de cPanel clic en el botón «Seleccionar Versión PHP». #

cpanel versionphp 1

Elija la versión de PHP que necesite. #

Para elegir, selecciona la versión y pulsa en «Set as current».

cpanel versionphp 2

Cambiar la versión de PHP para una página web, en una carpeta o subdominio. #

Cuando necesite una versión diferente a la establecida por defecto para una de sus aplicaciones, es necesario configurarla a través del fichero .htaccess del directorio principal de ese proyecto.

En este ejemplo vamos a usar el administrador de archivos de cPanel para editar el fichero, pero podrás hacerlo también si lo descargas por FTP, lo editas en local y lo subes de nuevo a tu alojamiento .

cpanel versionphp 3

Agregue las siguientes líneas de código. modifica la segunda línea en función de la versión que quieras establecer. En este ejemplo nosotros estableceremos la versión 5.6 de PHP.

				
					
<FilesMatch "\.(php4|php5|php3|php2|php|phtml)$">
SetHandler application/x-lsphp56
</FilesMatch>
				
			

Te indicamos la línea de código correspondiente a cada versión de PHP:

 

PHP 5.4

				
					SetHandler application/x-lsphp54
				
			

PHP 5.5

				
					SetHandler application/x-lsphp55
				
			

PHP 5.6

				
					SetHandler application/x-lsphp56
				
			

PHP 7.0

				
					SetHandler application/x-lsphp70
				
			

PHP 7.1

				
					SetHandler application/x-lsphp71
				
			

PHP 7.2

				
					SetHandler application/x-lsphp72
				
			

PHP 7.3

				
					SetHandler application/x-lsphp73
				
			

PHP 7.4

				
					SetHandler application/x-lsphp74
				
			

PHP 8.0

				
					SetHandler application/x-lsphp80
				
			

Asignar extensiones a una versión de PHP #

Dentro de «Seleccionar Versión PHP» también podemos seleccionar las extensiones de PHP que queremos habilitar en cada versión de PHP.

Simplemente debe seleccionar la versión de PHP en el desplegable, sin pulsar en «Set as current», y marcar las extensiones de PHP que necesite.

cpanel versionphp 4
Actualizado el enero 21, 2022
Como te pareció este articulo?